<!DOCTYPE html><!-- HTML 5 -->
<html lang="es-CL">

<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.capire.info/xmlrpc.php" />

<title>Reglas de Negocio – Business Rules</title>
<script>window.fbAsyncInit = function() {
				FB.init({
				  appId      : '',
				  xfbml      : true,
				  version    : 'v2.6'
				});
			  };</script><script>(function(d, s, id){
				 var js, fjs = d.getElementsByTagName(s)[0];
				 if (d.getElementById(id)) {return;}
				 js = d.createElement(s); js.id = id;
				 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appID=";
				 fjs.parentNode.insertBefore(js, fjs);
			   }(document, 'script', 'facebook-jssdk'));</script><link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="http://www.capire.info/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed de comentarios" href="http://www.capire.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Reglas de Negocio – Business Rules Feed de comentarios" href="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.8 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
		var disableStr = 'ga-disable-UA-831871-4';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-831871-4', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.capire.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='http://www.capire.info/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css?ver=1.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnewslite-stylesheet-css'  href='http://www.capire.info/wp-content/themes/dynamic-news-lite/style.css?ver=1.4.8' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.capire.info/wp-content/themes/dynamic-news-lite/css/genericons/genericons.css?ver=3.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnewslite-flexslider-css'  href='http://www.capire.info/wp-content/themes/dynamic-news-lite/css/flexslider.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnewslite-default-fonts-css'  href='//fonts.googleapis.com/css?family=Droid+Sans%3A400%2C700%7CFrancois+One&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='http://www.capire.info/wp-content/themes/dynamic-news-lite/css/themezee-related-posts.css?ver=20160421' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/www.capire.info","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.capire.info/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=6.2.8'></script>
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<script type='text/javascript' src='http://www.capire.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.capire.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.capire.info/wp-content/themes/dynamic-news-lite/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.capire.info/wp-content/themes/dynamic-news-lite/js/jquery.flexslider-min.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dynamicnews_slider_params = {"animation":"slide","speed":"7000"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.capire.info/wp-content/themes/dynamic-news-lite/js/slider.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dynamicnews_menu_title = "Menu";
/* ]]> */
</script>
<script type='text/javascript' src='http://www.capire.info/wp-content/themes/dynamic-news-lite/js/navigation.js?ver=20160719'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dynamicnews_sidebar_title = "Sidebar";
/* ]]> */
</script>
<script type='text/javascript' src='http://www.capire.info/wp-content/themes/dynamic-news-lite/js/sidebar.js?ver=20160421'></script>
<link rel='https://api.w.org/' href='http://www.capire.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.capire.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.capire.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='El traje digital del Emperador' href='http://www.capire.info/2018/03/01/el-traje-digital-del-emperador/' />
<meta name="generator" content="WordPress 4.9.4" />
<link rel="canonical" href="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/" />
<link rel='shortlink' href='http://www.capire.info/?p=1332' />
<link rel="alternate" type="application/json+oembed" href="http://www.capire.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.capire.info%2F2018%2F03%2F15%2Freglas-de-negocio-business-rules%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.capire.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.capire.info%2F2018%2F03%2F15%2Freglas-de-negocio-business-rules%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="http://www.capire.info/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" />
<meta name="twitter:partner" content="tfwp" /><link rel="icon" href="http://www.capire.info/wp-content/uploads/2017/07/cropped-icon-capire-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://www.capire.info/wp-content/uploads/2017/07/cropped-icon-capire-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.capire.info/wp-content/uploads/2017/07/cropped-icon-capire-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://www.capire.info/wp-content/uploads/2017/07/cropped-icon-capire-270x270.jpg" />

<meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Reglas de Negocio – Business Rules" /><meta name="twitter:description" content="Escribe Mario Saffirio Para entender qué es y cuál es el alcance de las reglas de negocio y cómo incorporarlas en un proyecto de implementación de procesos de negocios." /><meta name="twitter:image" content="http://www.capire.info/wp-content/uploads/2018/03/interior.jpg" />
</head>

<body class="post-template-default single single-post postid-1332 single-format-standard wp-custom-logo sliding-sidebar mobile-header-none">

<div id="wrapper" class="hfeed">

	<div id="topnavi-wrap">
		
	<div id="topnavi" class="container clearfix">

		
	</div>
	</div>

	<div id="header-wrap">

		<header id="header" class="container clearfix" role="banner">

			<div id="logo" class="clearfix">

				<a href="http://www.capire.info/" class="custom-logo-link" rel="home" itemprop="url"><img width="190" height="55" src="http://www.capire.info/wp-content/uploads/2017/07/cropped-logo-capire-portada.png" class="custom-logo" alt="" itemprop="logo" /></a>				
		<p class="site-title"><a href="http://www.capire.info/" rel="home"></a></p>

					
			<p class="site-description">Estrategia, Experiencia, Interacción.</p>

		
			</div>

			<div id="header-content" class="clearfix">
				
	<div id="header-social-icons" class="social-icons-wrap clearfix">
		<ul id="social-icons-menu" class="social-icons-menu"><li id="menu-item-419" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-419"><a href="http://twitter.com/Capire_info"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420"><a href="https://www.facebook.com/pages/Capireinfo/457947907596013#"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-584"><a href="https://www.linkedin.com/company/9386789"><span class="screen-reader-text">LinkedIn</span></a></li>
<li id="menu-item-608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-608"><a href="https://plus.google.com/u/0/101116030743918563893/about"><span class="screen-reader-text">Google+</span></a></li>
</ul>	</div>

			</div>

		</header>

	</div>

	<div id="navi-wrap">
		<nav id="mainnav" class="container clearfix" role="navigation">
			<ul id="mainnav-menu" class="main-navigation-menu menu"><li class="page_item page-item-406"><a href="http://www.capire.info/">Portada</a></li>
<li class="page_item page-item-16"><a href="http://www.capire.info/archivo/">Archivo</a></li>
<li class="page_item page-item-408"><a href="http://www.capire.info/equipo/">Equipo</a></li>
</ul>		</nav>
	</div>

	
	<div id="wrap" class="container clearfix">
		
		<section id="content" class="primary" role="main">
		
					
		
	<article id="post-1332" class="post-1332 post type-post status-publish format-standard has-post-thumbnail hentry category-destacado category-normal tag-bpm tag-transformacion">
	
		<h1 class="entry-title post-title">Reglas de Negocio – Business Rules</h1>		
		<div class="entry-meta postmeta clearfix"><span class="meta-date sep"><a href="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/" title="7:00 am" rel="bookmark"><time class="entry-date published updated" datetime="2018-03-15T07:00:39+00:00">Marzo 15, 2018</time></a></span><span class="meta-author sep"> <span class="author vcard"><a class="url fn n" href="http://www.capire.info/author/admin/" title="View all posts by admin" rel="author">admin</a></span></span>
	<span class="meta-comments">
		<a href="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/#respond">Comentar</a>	</span>

	</div>
		
		<img width="860" height="280" src="http://www.capire.info/wp-content/uploads/2018/03/interior-860x280.jpg" class="attachment-featured_image size-featured_image wp-post-image" alt="" />		
		<div class="entry clearfix">
			<span class="rt-reading-time" style="display: block;"><span class="rt-label">Tiempo de lectura: </span><span class="rt-time">6</span><span class="rt-label"> minutos</span></span><p>Escribe <strong><a href="https://www.linkedin.com/in/msaffirio/">Mario Saffirio</a></strong></p>
<p>Desde hace al menos veinte años, existen artículos referidos a las Reglas de Negocio que las describen desde una perspectiva del “negocio” o con un enfoque de “sistemas”. En este artículo pretendo mostrar como incorporarlas en un proyecto de implementación de procesos de negocios, para ello incluiré algunas definiciones comúnmente aceptadas a objeto de tener un mismo entendimiento, presentaré un método de recopilación y una lista de los usos posibles de éstas.</p>
<p>En primer lugar, tenemos que entender que las Reglas de Negocio siempre han estado presentes, lo que ocurre es que se han denominado de distintas maneras y se han tratado de manera parcializada. Es así como las tenemos en:</p>
<ul>
<li>Parámetros, por ejemplo tasas de impuestos, porcentajes de descuentos, listas de valores posibles, etc.</li>
<li>Procedimientos, flujos, rangos de autorización, instrucciones, manejo de excepciones, etc.</li>
<li>Datos, características del dato, clasificaciones, elementos que indican como tratarlo, p. ej: activo fijo, producto para la venta, materia prima, etc.</li>
</ul>
<p>Al no estar presente el concepto de Reglas de Negocios en un proyecto de implementación tradicional de un ERP  se genera una dispersión de la información correspondiente a las Reglas de Negocio, y una dilución de la responsabilidad de su mantenimiento y documentación.</p>
<p>La dispersión de la información se genera porque al no considerar el concepto en cuestión, las reglas se tratan en distintos objetos como ser: herramientas para la parametrización de un sistema, programas (codificación en duro – <em>hardcore</em>), estructuras de datos, reglamentos, manuales de procedimientos, conocimiento de los usuarios, entre otros. A su vez la dilución de las responsabilidades se genera por el proceso de generación; que nos es sistemático  en cuanto a la recopilación, identificación de los responsables y a la forma de documentar. En resumen, se mezclan responsabilidades propias del Negocio con las de Informática.</p>
<p>Por tanto, propongo que en un <strong>proyecto de implementación de procesos de negocio</strong>  se incluya una tarea con un método  sistemático para la recopilación y documentación de las Reglas de Negocio, tal que tanto las áreas del negocio, de auditoría e informática cuenten con una fuente única y válida para estos efectos.</p>
<p>En otras palabras a las dimensiones básicas de un proceso de negocio: Transacciones (Software), Organización (Estructura y Roles) y Procedimientos (Gobernabilidad) estaremos agregando la 4ta D, es decir, las Reglas de Negocio <a href="https://msaffirio.wordpress.com/2008/07/26/dimensiones-de-un-proceso-de-negocio-–-business-process-dimension/">[1]</a>.</p>
<p>&nbsp;</p>
<p><strong>Definiciones</strong></p>
<p>En general, todo el mundo sabe que es una “Regla de Negocios”, literalmente, es aquello que usamos para operar un negocio. Son las guías que determinan como se lleva el día-a-día de las operaciones. Sin reglas se estaría en una situación en la que cada decisión se resuelve en el momento, eligiendo alternativas caso a cado o <em>ad-hoc</em>, Y, este modo de operar es muy lento, costoso y puede generar resultados inconsistentes <a href="https://www.brcommunity.com/articles.php?id=b005">[2]</a>.</p>
<p>Para el término “Regla de Negocio” se tiene que para un especialista en procesos de negocio puede significar un conjunto de requerimientos asociados con los procesos, que están o no formalizados en una gramática o taxonomía  por algún tipo de mecanismo. Para el especialista en Base de Datos, puede ser un requerimiento específico que se satisface mediante la definición de alguna característica de los datos, que expresará en los valores posibles de un determinado campo <a href="http://www.dulcian.com/BRIM%20Documents/What%20Are%20Business%20Rules.htm">[3]</a>. Y, para la gente del negocio no son más que la <strong>“manera de hacer las cosas”</strong>.</p>
<p>Una Regla de Negocio define o limita un aspecto del negocio con el objeto de establecer una estructura o un grado de influencia que condiciona el comportamiento de los actores del negocio. A menudo las Reglas de Negocio están focalizadas en el control, en la forma de realizar los cálculos, otras permiten establecer las políticas, y así se tienen en cualquier actividad del negocio, que requiera que la gente actúe de una forma pre-establecida <a href="http://www.agilemodeling.com/artifacts/businessRule.htm">[4]</a>.</p>
<p>&nbsp;</p>
<p><strong>Qué NO son las Reglas de Negocio</strong></p>
<p>Las Reglas de Negocio <strong>no son software</strong>. Las Reglas de Negocio pueden ser <strong>implementadas</strong> en el software, pero esto a menudo representa sólo una parcialidad de sus definiciones, ya que partes importantes quedan expresadas en los Procedimientos Manuales. También existe la posibilidad, poco común por ahora, de habilitarlas mediante una Máquina de Reglas o un Sistema Experto. De modo que se debe entender que efectivamente las Reglas del Negocio, como su nombre lo indica, son parte del negocio y, no de alguna plataforma particular de hardware / software que pudiera soportarlas.</p>
<p>Las Reglas de Negocio de <strong>no son “Proceso”</strong>, de ninguna forma. Roger Burlton indica que: “Se debe separar el flujo del conocimiento”. Dónde las Reglas de Negocio representan la parte conocimiento que guía al flujo, de aquí  su nombre de Regla de Negocio <a href="https://www.brcommunity.com/articles.php?id=b005">[2]</a>.</p>
<p>&nbsp;</p>
<p><strong>Recopilación</strong></p>
<p>Dado que las Reglas del Negocio son <strong>conocimiento</strong>, su formulación –la acción de explicitarlas por escrito- es un proceso de recopilación, entendiendo que están en la cabeza de los empleados, a diferencia del <strong>flujo</strong> que habitualmente se documenta en un manual de procedimiento o en un <em>workflow</em>.</p>
<p>Podemos, entonces, decir que las Reglas de Negocio corresponden a un conocimiento <strong>tácito</strong>, por consiguiente el proceso de recopilación consistirá en convertir este conocimiento que tienen las personas en conocimiento <strong>explícito</strong> <a href="https://msaffirio.wordpress.com/2007/09/23/el-activo-conocimiento-de-informatica-knowledge-asset/">[5]</a>.</p>
<div class="perfect-pullquote vcard pullquote-align-left pullquote-border-placement-right"><blockquote><p>Es necesario tener presente que el poseer el conocimiento de determinadas Reglas de Negocio es poder. Y, que por tanto su recopilación puede tener complicaciones.</p></blockquote></div>
<p>Para proceder a la recopilación de las Reglas de negocios me parece un buen punto de partida tener en consideración los principios denominados  <em>“The business rule approach”</em> desarrollados por Ronald Ross, estos son:</p>
<ul>
<li>Deben ser explícitas y escritas.</li>
<li>Expresadas en términos sencillos.</li>
<li>Existen independientemente de los procedimientos y workflows (ej.: modelos).</li>
<li>Se construyen a partir de hechos, éstos se definen a partir de conceptos, los que a su vez se representan por medio de términos (ej.: glosarios).</li>
<li>Guían o influencian el comportamiento conforme a una forma pre-establecida.</li>
<li>Son motivadas por factores de negocios identificables e importantes.</li>
<li>Son accesibles a las partes autorizadas (ej.: tienen dueños).</li>
<li>Están en una fuente única (ej.: repositorio de reglas).</li>
<li>Son especificadas por las personas que tienen directa relación con ellas y que poseen el conocimiento relevante (ej.: los usuarios claves).</li>
<li>Son gestionadas –administradas- (ej.: son parte de la Gobernabilidad de los Procesos de Negocios)</li>
</ul>
<p>Una manera simple para recopilarlas es utilizar alguna herramienta para modelar, p. ej.: modelos EPC, al cual se le define un objeto denominado Regla de Negocio el que se enlaza con:</p>
<ul>
<li> Una función, esta ligazón permite relacionarla con Roles, secuencias de eventos y facilita su inclusión en la generación de procedimientos a partir de los EPC.</li>
</ul>
<p><img class="alignnone wp-image-1333" src="http://www.capire.info/wp-content/uploads/2018/03/reglas-de-negocio-2.jpg" alt="" width="579" height="236" /></p>
<figure id="attachment_471" class="wp-caption aligncenter" data-shortcode="caption"><figcaption class="wp-caption-text">Regla de Negocio conectada a una Función en diagrama EPC</figcaption><figcaption></figcaption></figure>
<ul>
<li>A un documento –texto, planilla, etc.- donde se incluye la descripción detallada, para este efecto recomiendo utilizar la formulación <a href="http://www.rulespeak.com/es/downloads.php">Rule Speak [6]</a> , que la pueden solicitar en español en el enlace indicado. Si bien, es cierto que algunos expertos encuentran compleja la utilización de Rule Speak a mi parece que simplifican el proceso de documentación, dado que las definiciones se especifican en español, con un expresiones sin ambigüedades.</li>
</ul>
<p>&nbsp;</p>
<p><img class="alignnone size-full wp-image-1334" src="http://www.capire.info/wp-content/uploads/2018/03/reglas-de-negocio-1.jpg" alt="" width="784" height="330" srcset="http://www.capire.info/wp-content/uploads/2018/03/reglas-de-negocio-1.jpg 784w, http://www.capire.info/wp-content/uploads/2018/03/reglas-de-negocio-1-768x323.jpg 768w" sizes="(max-width: 784px) 100vw, 784px" /></p>
<figure id="attachment_473" class="wp-caption aligncenter" data-shortcode="caption"><figcaption class="wp-caption-text">Ejemplo de especificación de una Regla de Negocios usando Rule Speak.</figcaption></figure>
<p>&nbsp;</p>
<p>El proceso de recopilación puede ser apoyado técnicamente por Business Process Expert (BPX) <a href="https://msaffirio.wordpress.com/2008/09/30/business-process-expert-–-bpx/">[7]</a> pero, la responsabilidad sobre el contenido y mantenimiento de la Regla de Negocio es del <strong>Dueño de Proceso de Negocio</strong>, quien puede obtener información detallada de las mismas por medio de los Usuarios Claves –<em>Key Users</em>.</p>
<p>La etapa del proyecto de implementación de procesos de negocios  en la cual me parece adecuado realizar la recopilación de las Reglas de Negocios es la de Diseño o <em>Business Blueprint</em>.</p>
<p>&nbsp;</p>
<p><strong>Usos</strong><br />
Entre otros, el disponer de las Reglas de Negocio en un repositorio y formalmente descritas –por ejemplo en ARIS, donde pueden ser un objeto  conectado a una función en un modelo EPC y a documentos -por ejemplo en SAP Solution Manager, con sus respectivas especificaciones– se logran los resultados siguientes:</p>
<ul>
<li>Visibilidad y transparencia de las definiciones de las Reglas de Negocio, tanto para la gente del negocio como para la de informática.</li>
<li>Gobernabilidad para las Reglas de Negocio: procedimiento para su creación y mantenimiento sistemático con responsable único y del área de negocios.</li>
<li>Mayor agilidad para abordar los cambios en el negocio.</li>
<li>Facilitan las auditorías – recorridos- de los procesos de negocios.</li>
<li>Lista de Reglas de Negocio por: Proceso, Responsable, Rol, Funciones.</li>
<li>Clasificación por uso: Parametrización, Datos o Procedimientos.</li>
<li>Documentación disponible centralizadamente.</li>
</ul>
<p>&nbsp;</p>
<p><strong>Referencias</strong><br />
[1] https://msaffirio.wordpress.com/2008/07/26/dimensiones-de-un-proceso-de-negocio-%e2%80%93-business-process-dimension/<br />
[2] http://www.brcommunity.com/b005.php<br />
[3] http://www.dulcian.com/BRIM%20Documents/What%20Are%20Business%20Rules.htm<br />
[4] http://www.agilemodeling.com/artifacts/businessRule.htm<br />
[5] https://msaffirio.wordpress.com/2007/09/23/el-activo-conocimiento-de-informatica-knowledge-asset/<br />
[6] http://www.rulespeak.com/es/downloads.php</p>
<p>[7] https://msaffirio.wordpress.com/2008/09/30/business-process-expert-–-bpx/</p>
<p>&nbsp;</p>
<p>*************<br />
Artículo publicado originalmente en <a href="https://msaffirio.wordpress.com">&#8220;Mario Saffirio C. Tecnologías de la Información y Procesos de Negocios (BPM)&#8221;</a> , como <a href="https://msaffirio.wordpress.com/2011/08/20/reglas-de-negocio-business-rules/">&#8220;Reglas de negocio &#8211; Business Rules&#8221;</a></p>
<p>Publicado en Capire.info, con autorización del autor. Toda reproducción total o parcial debe incluir la fuente original y a su autor.</p>
<!-- Simple Share Buttons Adder (7.3.10) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left">Compartir:<a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/&amp;text=Reglas%20de%20Negocio%20%E2%80%93%20Business%20Rules%20en%20%40capire_info%20"  target=&quot;_blank&quot; ><img src="http://www.capire.info/wp-content/plugins/simple-share-buttons-adder/buttons/plain/twitter.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/"  target=&quot;_blank&quot; ><img src="http://www.capire.info/wp-content/plugins/simple-share-buttons-adder/buttons/plain/linkedin.png" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /></a><a data-site="" data-facebook="mobile" class="ssba_facebook_share" data-href="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/" href="https://www.facebook.com/dialog/share?app_id=&display=popup&href=http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/&redirect_uri=http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/"  target=&quot;_blank&quot; ><img src="http://www.capire.info/wp-content/plugins/simple-share-buttons-adder/buttons/plain/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a></div></div>			<!-- <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/"
    dc:identifier="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/"
    dc:title="Reglas de Negocio – Business Rules"
    trackback:ping="http://www.capire.info/2018/03/15/reglas-de-negocio-business-rules/trackback/" />
</rdf:RDF> -->
			<div class="page-links"></div>			
		</div>
		
		<div class="postinfo clearfix">
				<span class="meta-tags">
					tagged with <a href="http://www.capire.info/tag/bpm/" rel="tag">BPM</a>, <a href="http://www.capire.info/tag/transformacion/" rel="tag">Transformación</a>				</span>

			</div>

	</article>
		
					
					
		


	<div id="comments">
	
		
						<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Agregar un comentario <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/03/15/reglas-de-negocio-business-rules/#respond" style="display:none;">Cancelar respuesta</a></small></h3>			<form action="http://www.capire.info/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Su dirección de correo no se hará público.</span> Los campos requeridos están marcados <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comentario</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Nombre <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Correo <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Sitio web</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Publicar comentario" /> <input type='hidden' name='comment_post_ID' value='1332' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="79c1741c46" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="31"/></p>			</form>
			</div><!-- #respond -->
			
	</div>

		
		</section>
		
		
	<section id="sidebar" class="secondary clearfix" role="complementary">

		<aside id="search-4" class="widget widget_search clearfix">	<form role="search" method="get" class="search-form" action="http://www.capire.info/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="Buscar &hellip;" value="" name="s">
		</label>
		<button type="submit" class="search-submit">
			<span class="genericon-search"></span>
		</button>
	</form>

</aside><aside id="text-4" class="widget widget_text clearfix"><h3 class="widgettitle"><span>Capire.info</span></h3>			<div class="textwidget">El objetivo es entender, compartir y crear conocimiento para  promover la vida digital de las personas y las organizaciones.</div>
		</aside><aside id="tag_cloud-4" class="widget widget_tag_cloud clearfix"><h3 class="widgettitle"><span>Temas</span></h3><div class="tagcloud"><a href="http://www.capire.info/tag/accesibilidad/" class="tag-cloud-link tag-link-39 tag-link-position-1" style="font-size: 12.341085271318pt;" aria-label="accesibilidad (4 items)">accesibilidad</a>
<a href="http://www.capire.info/tag/ai/" class="tag-cloud-link tag-link-30 tag-link-position-2" style="font-size: 16.790697674419pt;" aria-label="AI (12 items)">AI</a>
<a href="http://www.capire.info/tag/banca/" class="tag-cloud-link tag-link-41 tag-link-position-3" style="font-size: 18.418604651163pt;" aria-label="banca (17 items)">banca</a>
<a href="http://www.capire.info/tag/bpm/" class="tag-cloud-link tag-link-42 tag-link-position-4" style="font-size: 9.953488372093pt;" aria-label="BPM (2 items)">BPM</a>
<a href="http://www.capire.info/tag/branding/" class="tag-cloud-link tag-link-26 tag-link-position-5" style="font-size: 9.953488372093pt;" aria-label="branding (2 items)">branding</a>
<a href="http://www.capire.info/tag/comportamiento/" class="tag-cloud-link tag-link-32 tag-link-position-6" style="font-size: 17.767441860465pt;" aria-label="comportamiento (15 items)">comportamiento</a>
<a href="http://www.capire.info/tag/cultura/" class="tag-cloud-link tag-link-36 tag-link-position-7" style="font-size: 19.06976744186pt;" aria-label="cultura (20 items)">cultura</a>
<a href="http://www.capire.info/tag/cultura-organizacional/" class="tag-cloud-link tag-link-48 tag-link-position-8" style="font-size: 21.240310077519pt;" aria-label="cultura organizacional (32 items)">cultura organizacional</a>
<a href="http://www.capire.info/tag/diseno/" class="tag-cloud-link tag-link-27 tag-link-position-9" style="font-size: 17.767441860465pt;" aria-label="diseño (15 items)">diseño</a>
<a href="http://www.capire.info/tag/egob/" class="tag-cloud-link tag-link-35 tag-link-position-10" style="font-size: 14.511627906977pt;" aria-label="eGob (7 items)">eGob</a>
<a href="http://www.capire.info/tag/emocion/" class="tag-cloud-link tag-link-40 tag-link-position-11" style="font-size: 11.255813953488pt;" aria-label="emoción (3 items)">emoción</a>
<a href="http://www.capire.info/tag/entrevista/" class="tag-cloud-link tag-link-28 tag-link-position-12" style="font-size: 8pt;" aria-label="entrevista (1 item)">entrevista</a>
<a href="http://www.capire.info/tag/estrategia/" class="tag-cloud-link tag-link-20 tag-link-position-13" style="font-size: 21.674418604651pt;" aria-label="estrategia (35 items)">estrategia</a>
<a href="http://www.capire.info/tag/estudios/" class="tag-cloud-link tag-link-25 tag-link-position-14" style="font-size: 15.054263565891pt;" aria-label="estudios (8 items)">estudios</a>
<a href="http://www.capire.info/tag/experiencia/" class="tag-cloud-link tag-link-38 tag-link-position-15" style="font-size: 21.240310077519pt;" aria-label="experiencia (32 items)">experiencia</a>
<a href="http://www.capire.info/tag/experiencia-de-cliente/" class="tag-cloud-link tag-link-45 tag-link-position-16" style="font-size: 15.596899224806pt;" aria-label="Experiencia de Cliente (9 items)">Experiencia de Cliente</a>
<a href="http://www.capire.info/tag/gobierno-digital/" class="tag-cloud-link tag-link-46 tag-link-position-17" style="font-size: 9.953488372093pt;" aria-label="Gobierno Digital (2 items)">Gobierno Digital</a>
<a href="http://www.capire.info/tag/innovacion/" class="tag-cloud-link tag-link-44 tag-link-position-18" style="font-size: 22pt;" aria-label="innovación (38 items)">innovación</a>
<a href="http://www.capire.info/tag/intranet/" class="tag-cloud-link tag-link-29 tag-link-position-19" style="font-size: 9.953488372093pt;" aria-label="intranet (2 items)">intranet</a>
<a href="http://www.capire.info/tag/mobile/" class="tag-cloud-link tag-link-50 tag-link-position-20" style="font-size: 8pt;" aria-label="mobile (1 item)">mobile</a>
<a href="http://www.capire.info/tag/psicologia/" class="tag-cloud-link tag-link-34 tag-link-position-21" style="font-size: 14.511627906977pt;" aria-label="psicología (7 items)">psicología</a>
<a href="http://www.capire.info/tag/rse/" class="tag-cloud-link tag-link-24 tag-link-position-22" style="font-size: 8pt;" aria-label="rse (1 item)">rse</a>
<a href="http://www.capire.info/tag/servicio/" class="tag-cloud-link tag-link-31 tag-link-position-23" style="font-size: 9.953488372093pt;" aria-label="servicio (2 items)">servicio</a>
<a href="http://www.capire.info/tag/transformacion/" class="tag-cloud-link tag-link-47 tag-link-position-24" style="font-size: 18.093023255814pt;" aria-label="Transformación (16 items)">Transformación</a>
<a href="http://www.capire.info/tag/usabilidad/" class="tag-cloud-link tag-link-37 tag-link-position-25" style="font-size: 15.054263565891pt;" aria-label="usabilidad (8 items)">usabilidad</a>
<a href="http://www.capire.info/tag/ux/" class="tag-cloud-link tag-link-43 tag-link-position-26" style="font-size: 19.720930232558pt;" aria-label="UX (23 items)">UX</a></div>
</aside><aside id="text-6" class="widget widget_text clearfix"><h3 class="widgettitle"><span>Suscribirse por email</span></h3>			<div class="textwidget"><form style="border: 0px solid #ccc; padding: 0px; text-align: center;" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow">Ingresa tu email:<input style="width: 140px;" name="email" type="text" />

<input name="uri" type="hidden" value="capire" /><input name="loc" type="hidden" value="es_ES" /><input type="submit" value="Suscribir" />

<p>Delivered by <a href="http://feedburner.google.com" target="_blank">FeedBurner</p></a>

</form></div>
		</aside><aside id="text-8" class="widget widget_text clearfix"><h3 class="widgettitle"><span>Feed RSS</span></h3>			<div class="textwidget"><a href="http://feeds.feedburner.com/Capireinfo" title="Subscríbete al RSS de Capire" rel="alternate" type="application/rss+xml"><img src="//feedburner.google.com/fb/images/pub/feed-icon32x32.png" alt="" style="border:0;margin-right:10px;"/></a><a href="http://feeds.feedburner.com/Capireinfo" title="Subscríbete al RSS de Capire" rel="alternate" type="application/rss+xml">Subscríbete al RSS de Capire</a></div>
		</aside>
	</section>
	</div>
	

	<div id="footer-wrap">

		<footer id="footer" class="container clearfix" role="contentinfo">

			
				<nav id="footernav" class="clearfix" role="navigation">
									</nav>

			
			<div id="footer-text">
				
	<span class="credit-link">
		Powered by <a href="http://wordpress.org" title="WordPress">WordPress</a> and <a href="https://themezee.com/themes/dynamicnews/" title="Dynamic News WordPress Theme">Dynamic News</a>.	</span>

				</div>

		</footer>

	</div>

</div><!-- end #wrapper -->

<link rel='stylesheet' id='simple-share-buttons-adder-ssba-css'  href='http://www.capire.info/wp-content/plugins/simple-share-buttons-adder/css/ssba.css?ver=4.9.4' type='text/css' media='all' />
<style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>
	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 35px !important;
									padding: 10px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
									box-sizing: unset;
								}
								
								.ssba .fb-save
								{
								padding: 10px;
								line-height: 30px;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									background: none;
									
									font-size: 16px;
									
									font-weight: bold;
								}
								
</style>
<script type='text/javascript' src='http://www.capire.info/wp-content/plugins/simple-share-buttons-adder/js/ssba.js?ver=4.9.4'></script>
<script type='text/javascript'>
Main.boot( [] );
</script>
<script type='text/javascript' src='http://www.capire.info/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script async="async" type='text/javascript' src='http://www.capire.info/wp-content/plugins/akismet/_inc/form.js?ver=4.0.2'></script>
</body>
</html>
